Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Server & Application Monitor (SAM) > Unexpected error occurred - Call was canceled by the message filter. (Exception from HRESULT: 0x80010002 (RPC_E_CALL_CANCELED))

Unexpected error occurred - Call was canceled by the message filter. (Exception from HRESULT: 0x80010002 (RPC_E_CALL_CANCELED))

Updated: September 22, 2016

Overview

This article discusses the error message: 

Unexpected error occurred. Call was canceled by the message filter. (Exception from HRESULT: 0x80010002 (RPC_E_CALL_CANCELED)) which can be seen in the web console 

 

Environment

  • All versions of SAM

Cause 

 

  • This is caused by WMI issues on target server.

Resolution


Scope the Issue:

  1. Log in to the Target Server and restart the WMI service.
  2. If you are unable to restart, run a Wbemtest locally to test WMI connectivity on the node.
  3. If the Wbemtest Fails, open a ticket with Microsoft as this is an issue related to the server.

 

Workaround:

Edit the Application Monitor and change the fetching Method from WMI to RPC (Remote Procedure Call).

 

Last modified
22:03, 21 Sep 2016

Tags

Classifications

Public