Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Server & Application Monitor (SAM) > Unable to start an Orion agent service that monitors a node running Windows 2012 R2 after stopping it with the Service Control Manager

Unable to start an Orion agent service that monitors a node running Windows 2012 R2 after stopping it with the Service Control Manager

Updated July 19, 2017

Overview

After using the Service Control Manager to stop an Orion agent service that monitors a node running Windows 2012 R2, that Agent service cannot be restarted.

 

Environment

  • All SAM versions
  • Windows 2012 R2

 

Cause 

A job stored in the JobEngine plugin database is normally deleted from the database after it’s executed. In this situation, the job to stop the Orion agent service (created when the Orion agent service was stopped with the Service Control Manager) was executed, which stopped the Orion agent and polling. Because polling was stopped, the job was not deleted from the JobEngine plugin database. 

Note: The JobEngine plug-in database is located on the agent machine.

 

When attempting to start, the Orion agent automatically checks the JobEngine plug-in database for missed jobs. In this case, the Orion agent finds the same job that wasn’t deleted and executes it again, which stops the Orion agent and polling, and the job is not deleted from the JobEngine plugin database. This results in an endless cycle where the Orion agent cannot be completely started.

 

Resolution

Reinstall the affected Orion agent and delete the JobEngine plugin database, which will remove any jobs that are instructing the Orion agent to stop.

 

Steps

  1. Uninstall the Orion agent that won’t start.
  2. Delete the JobEngine plug-in database: %ProgramData%\Solarwinds\JobEngine.v2.agent\Data\JobEngine35.sdf
  3. Re-install the affected Orion agent.
  4. Start the Orion agent. 
  5. Restart Orion Poller to restart polling.

 

Do not use the Service Control Manager to start or stop the affected Orion agent. Start and stop it manually.

For example, using the command prompt:
net stop "SolarWinds Agent"
net start "SolarWinds Agent"

 

 

Last modified
14:56, 27 Jul 2017

Tags

Classifications

Public