Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Server & Application Monitor (SAM) > The installed PowerShell WebAdministration module cannot be imported  into the PowerShell session. System.ComponentModel.Win32Exception: Access is denied

The installed PowerShell WebAdministration module cannot be imported  into the PowerShell session. System.ComponentModel.Win32Exception: Access is denied

Updated December 23, 2016

Overview

After changing the AppInsight for IIS template to Agent Based Polling, the previously working template displays the error:

The installed PowerShell WebAdministration module cannot be imported 
into the PowerShell session. System.ComponentModel.Win32Exception: Access is denied 

Environment

SAM 6.2 and later

Cause 

This occurs because of the change in permission that the template now requires. Previously, the PowerShell sessions were run through a specified administrator account but now they are executed in the context of the LocalSystem account which the agent service runs under.

Resolution

 

  1. Open the Orion Web Console.
  2. Go to the AppInsight for IIS application.
  3. Edit the Application Monitor.
  4. Expand Advanced and verify that it is set to Agent. 
  5. Verify that credentials are set to Inherit Credentials From Node.
  6. Click Configure Server.

This allows the LocalSystem account to access the WebAdministration PowerShell Snap-in.

 

 

Last modified
17:18, 29 Mar 2017

Tags

Classifications

Public