Submit a ticketCall us

Announcing NCM 7.7
With NCM 7.7, you can examine the rules that make up an access control list for a Cisco ASA device. Then you can apply filters to display only rules that meet the specified criteria, order the rules by line number or by the hit count, and much more.
See new features and improvements.

Home > Success Center > Server & Application Monitor (SAM) > Real-time Process Explorer polling times out

Real-time Process Explorer polling times out

Overview

Real-time Process Explorer polling times out. 

Environment

SAM v5.0 and later

Cause

The following are the possible causes:

  • By default, the Real-Time Process Explorer timeout period to start polling is one minute. If it takes longer than this, increasing the timeout period can help.
  • The SAM version on the additional poller is older than the version on the primary poller.

Resolution

Warning:

  • Consult your System Administrator before performing the following procedure.
  • SolarWinds strongly recommends that you only edit the SolarWinds.APM.BusinessLayer.dll.config file as instructed. Any additional modifications may result in system performance issues or may create an error state.
  • Save a copy of the original SolarWinds.APM.BusinessLayer.dll.config file to your local drive as a backup file, in case you need to roll back later.
  • Increasing the timeout value to more than 2 minutes is not recommended unless other parameters are adjusted accordingly.
  1. Open the SolarWinds.APM.BusinessLayer.dll.config file in a text editor (c:\Program Files(x86)\SolarWinds\Orion\APM\). 
  2. Insert the following line directly after the  </configSections> line:
    <realTimeProcessExplorer pollingTimeout="00:03:00" jobLifetime="00:05:00" reschedulePollingBeforeEnd="00:01:00" pollInterval="00:00:05"/>
  3. Restart the SolarWinds Orion Module Engine service to apply this change.

 

Alternatively, you can upgrade the version of SAM on all additional pollers.

Last modified
21:04, 30 Nov 2016

Tags

Classifications

Public