Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Server & Application Monitor (SAM) > Powershell scripts stop working after upgrading to .Net 4.0

Powershell scripts stop working after upgrading to .Net 4.0

Overview

Powershell scripts stop working after upgrading to .Net 4.0.

Environment

All SAM versions

Cause

This issue can be fixed by adding legacy .Net compatibility into the configuration file of the SAM/APM module/application that launches Powershell monitors.

 

Note: This is a known issue and will be addressed in a future release.

Resolution

If possible, upgrade to SAM 5.2 or higher. If this is not possible, follow the steps below by updating the highlighted content from the Original File Content example to the Fixed File Content example:

 

Apply the change inside the Job Engine worker’s configuration files :
“c:\Program Files (x86)\Common Files\SolarWinds\JobEngine.v2\SWJobEngineWorker2.exe.config” and
“c:\Program Files (x86)\Common Files\SolarWinds\JobEngine.v2\SWJobEngineWorker2x64.exe.config”

Original file content:

 

code2.png

 

Last modified
21:34, 30 Nov 2016

Tags

Classifications

Public