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Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > WMI-based monitor poll fails with Access Denied error when using agent

WMI-based monitor poll fails with Access Denied error when using agent

Created by Chris Foley, last modified by MindTouch on Jun 23, 2016

Views: 2,757 Votes: 0 Revisions: 3

Updated June 13, 2016

Overview

This article addresses the issue where WMI-based monitors pass their test but polling fails with an Access Denied error when using an agent.

 

The Application's debug log files look like the following:

DEBUG LOGS FROM COMPONENT TEST
---------------------------------------------------------
2016-06-03 13:26:24,503 [STP SmartThreadPool Thread #1] [C938] DEBUG SolarWinds.APM.Probes.WMI.WMIHelper - Trying to connect to '127.0.0.1' as '' with following scope properties: Path='\\.\root\CIMV2', Username='', Authority=''

2016-06-03 13:26:24,503 [STP SmartThreadPool Thread #1] [C938] DEBUG SolarWinds.APM.Probes.CacheDictionary`2 - Value for key 'WMI_127.0.0.1_root\CIMV2__757602046' retrieved.



DEBUG LOGS FROM APPLICATION POLL
----------------------------------------------------------
2016-06-03 13:26:22,148 [STP Pool:2 Thread #0] [C0] DEBUG SolarWinds.APM.Probes.WMI.WMIHelper - Trying to connect to '192168.1.111' as '' with following scope properties: Path='\\192.168.1.111\root\CIMV2', Username='', Authority=''

2016-06-03 13:26:22,163 [STP Pool:2 Thread #0] [C0] DEBUG SolarWinds.APM.Probes.WMI.WMIHelper - Connection Attempt to 192.168.1.111 as Failed.
System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Environment

SAM 6.2.3 or earlier

Cause 

This occurs when the monitor uses the wrong WMI path when performing the actual poll. As the WMI Query is being run locally, it should be using the path \\.\root\CIMV2 or \root\CIMV2

This is a known issue in SAM 6.2.3 or earlier.

 

Resolution

Upgrade to SAM 6.2.4, where this issue has been fixed. If you are unable to upgrade the application, perform the following workaround:

  1. On the Web Console, go to Settings > Manage Nodes.
  2. Select the node in question and click Edit Properties.
  3. Next to the Polling IP Address field , click Select IP Address.
  4. Choose an IP address other than the one the node is currently using.
  5. Click Submit.

 

 

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