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Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > SAM Application Polling Rate showing high usage

SAM Application Polling Rate showing high usage

Created by Tiarnan Stacke, last modified by Jonathon.Privett on Oct 10, 2017

Views: 1,310 Votes: 1 Revisions: 4

Updated

Overview

This article addresses the SAM Application Polling Rate showing an artificially high percentage of polling on the Polling Engine page in the Orion Web Console.

If your application polling rate is not artificially high - but instead is actually just high because of overloading your poller with SAM applications then these resolution steps will not help. You'll need to remove/disable applications or load balance nodes off of the problematic poller to an additional to resolve the high polling rate.

Environment

SAM 6.2.4 and earlier

Cause 

This occurs because of orphaned data within the JobEngine SDF file which can cause incorrect calculations.

Resolution

Note: The following solution will temporarily stop your polling as services have to be shut down.

  1. Shut down all services in Orion Service Manager.
  2. Go to C:\ProgramData\SolarWinds\JobEngine.v2\Data
  3. Rename the JobEngine35.sdf file to JobEngine35_OLD.sdf
  4. Create a copy of JobEngine35 - Blank.sdf one and rename it to JobEngine35.sdf
  5. Right-click on the new JobEngine35.sdf and select Properties.
  6. Deselect Read-only and click OK.
  7. Go to C:\ProgramData\SolarWinds\Collector\Data
  8. Rename PollingController.sdf to PollingController.sdf.OLD 
  9. Create a copy of PollingController-Blank.sdf and rename it to PollingController.sdf
  10. Right-click on the new files and select Properties.
  11. Deselect Read-only and click OK.
  12. Restart the services in Orion Service Manager.

 

 

 

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