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Process Monitoring on AS/400 produces error in SAM

Updated December 19, 2018

Overview

You can browse and select processes for AS/400 monitoring but actual polling results in an SNMP monitor error: No process info found.

Environment

All SAM versions

Cause

This is a known issue with this particular device. To poll processes effectively, SAM needs to know how much CPU & Memory the process is consuming. This is part of the standard HOST-RESOURCES MIB.

IBM has a watered-down SNMP agent on the AS/400 provides limited information via SNMP. SAM can see the list of processes, but when trying to poll, critical pieces of information are missing.

Resolution

There are a few vendors with custom SNMP agents you can install to replace the built in SNMP agent with a more complete one. For example, you can purchase a third-party agent from Comtek. See http://www.comtekservices.com/os400.html. (© 2018 COMTEK Services, LLC., obtained from www.comtekservices.com on December 19, 2018.)

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

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