Submit a ticketCall us

AnnouncementsChange Is Inevitable

Get valuable help when it comes to tracking and monitoring changes. SolarWinds® Server Configuration Monitor (SCM) is designed to help you: detect, track, and receive alerts when changes occur, correlate system performance against configuration changes, compare server and application configuration against custom baselines, and verify application and system changes.

Learn more.

Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > PowerShell monitor error: You should update your PowerShell to PowerShell 2.0

PowerShell monitor error: You should update your PowerShell to PowerShell 2.0

Updated August 16, 2018

Overview

This article discusses the issue where the PowerShell application monitor returns the following error even when the PowerShell version used is 4.0: 

WARNING: You should update your PowerShell to PowerShell 2.0 

SolarWinds SAM is compatible with PowerShell 2.0 or later, including v. 4.0. (You need at least PowerShell 2.0 to support remote execution.)

Environment

SAM 6.2 and later

Cause 

The warning is thrown by Get-VMJob from the endpoint (target Server where the SAM template is assigned) itself and not by Orion.

Resolution

  1. Verify that the server where the template is assigned is actually running PowerShell 4.0.

  2. Confirm where the problem resides. Refer to PowerShell Veeam backup status report (© 2017 Veeam, available at https://forums.veeam.com/, obtained on January 19, 2017.)

  3. Take the problematic script, open PowerShell ISE and connect remotely to the node using the same credentials and then check if the ISE console displays the same warning.

  4. Confirm that the warning is thrown by Get-VMJob  using Veeam cmdlets. This means that the problem is on the target node and not in Orion.

  5. Use the -WarningVariable common parameter to address the warning. Refer to Saving Warnings to a variable in PowerShell (© 2017 Stack Exchange, Inc., available at http://stackoverflow.com/, obtained on January 19, 2017.)

PowerShell requires .NET Framework 3.5.x. but SAM 6.5 — 6.6.1 use .NET Framework 4.6.2. You can use Server Manager's Add Roles and Features wizard to add .NET Framework 3.5, if necessary.

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

Last modified

Tags

Classifications

Public