Submit a ticketCall us

AnnouncementsAre You “Flying Blind?”

When it comes to your complex IT infrastructure, you want to ensure you have a good grasp of what’s going on to avoid any fire drills that result from guesswork. Read our white paper to learn how proactively monitoring your IT environment can help your organization while giving you peace of mind.

Get your free white paper.

Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > Import fails after scheduled discovery in SAM

Import fails after scheduled discovery in SAM

Updated December 14, 2018

Overview

This article describes how a scheduled discovery can fail if the Orion Platform cannot save imported data to the Orion database because the number of HTTPS connections exceeds .NET Framework limits.

Here is a partial example of error messages that may appear in Core Business Layer logs after the discovery fails: 

018-11-28 09:53:03,602 [32] WARN SolarWinds.APM.Common.APMBusinessLayerProxy - (null) An error occured when connecting to the communication channel.
2018-11-28 09:53:03,602 [32] ERROR SolarWinds.Orion.Core.BusinessLayer.DiscoveryImportManager - (null) Exception occurred during discovery import
System.ServiceModel.ServerTooBusyException: Server 'xxx:17777/orion/apm/businesslayer' sent back a fault indicating it is too busy to process the request. Please retry later. Please see the inner exception for fault details. ---> System.ServiceModel.FaultException: There are too many pending secure conversations on the server. Please retry later.

To learn more about running discovery jobs and importing discovered results into the Orion database, watch the Run Discovery Jobs and Import Results - Video.

Environment

  • SAM 6.2.4 and later

Cause

When a large quantity of nodes is added at the same time, the number of HTTPS connections required can exceed the limit for clients running Microsoft .NET Framework 3.5. The default limit for pending sessions is 128. This is known .NET 3.x issue that was fixed in .NET ; see 

Resolution

  • This issue is slated to be fixed in a future release.
  • Reduce the number of nodes being added at the same time. 
  • Split the nodes into groups and then try to add one group at a time.
Last modified

Tags

Classifications

Public