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Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > Failed to detect ORACLE HOME directory in SAM

Failed to detect ORACLE HOME directory in SAM

Updated August 3rd, 2018

Overview

When testing the Oracle User Experience Monitor template against a node, it returns the Failed to detect ORACLE HOME directory error. This is despite the fact that the system hosting the poller in charge of the node has all of the required Oracle drivers and all SQLPlus tests work fine.

Environment

SAM 6.3

Cause 

Application/Template is set to use Agent and Node is set to use a Polling Method of Agent, however, Linux does not have Oracle client installed.

Resolution

Set the Application/Template to use a Preferred Polling Method of Agentless.  

  1. Go to Settings > SAM Settings.
  2. Click Manage Templates.
  3. Find and select the Oracle Database template > click Edit.
  4. Open the Advanced section.
  5. Set Preferred Polling Method to Agentless.
  6. Click Submit.

 

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