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Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > Connection Timeout: Job cancelled by scheduler

Connection Timeout: Job cancelled by scheduler

Updated June 1, 2016

Overview

This article provides brief information and steps to resolve the following error:

Connection Timeout: job cancelled by scheduler

Environment

All SAM versions        

Cause

The error is caused by either of the following:

  • Corrupt performance counters
  • No connectivity between devices
  • Over burdened Job Engine handling failing components

Resolution

Note: Resolution 1 and 2 are to be performed on the Target system, not the system hosting the SAM installation or the Additional Poller installation.

 

Resolution 1:

Rebuild performance counters. See How to Rebuild Performance Counters Library (© 2017 Microsoft, available at https://support.microsoft.com, obtained on April 27, 2017.) for more information. 

 

Resolution 2:

Warning: SolarWinds strongly recommends that you create a backup of your registry. The following procedure can create permanent changes on your registry. 

  1. Create a backup of your registry (© 2017 Microsoft, available at https://support.microsoft.com, obtained on April 27, 2017.).
  2. Open the Registry editor. 
    1. Click Start > Run.
    2. Enter CMD.
    3. Enter regedit
  3. Expand HKLM > Software > Microsoft\Windows NT >  CurrentVersion > Perflib.
    • ( HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\Perflib\default may not have a value set at all, if so simply add 0 to the value )
  4. Right-click Default.
  5. Check the Data Value. It must NOT be set to 1.
  6. Reboot the server. 

 

Resolution 3:

Go through all of the currently assigned applications and remove any that are failing as down or unknown. If you don't want to remove them figure out why they are failing and resolve it. Failures and unknown components take much much longer to process because the scheduler has to wait for the timeout before it finally gives up.

 

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