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Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > AppInsight for Exchange: Performance counter not found

AppInsight for Exchange: Performance counter not found

Created by Seamus.Enright, last modified by christopher.roy on Oct 15, 2018

Views: 2,509 Votes: 0 Revisions: 10

Overview

The following error message appears when using AppInsight for Exchange:

Performance counter not found.

Environment

  • SAM 6.2 and later
  • AppInsight for Exchange

Cause 

The performance counter is broken.

Resolution 

Repair the counter using the following steps:
Note: The files provided in this solution are valid for Exchange 2013 (V15). The missing files will depend on the missing category. find the appropriate tuple of (missing) files in the DVD:\Setup\Perf folder.

  1. Close all PerfMon windows.
  2. Open the following on the Exchange Server:
    C:\Program Files\Microsoft\Exchange Server\V15\Setup\Perf  
    If the counter files are not present:
    Copy missing performance counter files from source DVD to C:\Program Files\Microsoft\Exchange Server\V15\Setup\Perf.
    • Files included:
      • IndexAgentPerfCounters.h
      • IndexAgentPerfCounters.ini
      • IndexAgentPerfCounters.xml
  3. Open an elevated instance of Exchange Management Shell (Run As Administrator).
  4. Run the following command:
    • Add-Pssnapin Microsoft.Exchange.Management.PowerShell.Setup
  5. Run the following command:
    • New-PerfCounters -DefinitionFileName "C:\Program Files\Microsoft\Exchange Server\V15\Setup\Perf\IndexAgentPerfCounters.xml".
  6. Check Windows Application Log to verify performance counters loaded properly.
  7. After verification, click Poll Now on the Orion Web Console.
    Within a few minutes this counter should no longer be in an unknown state. 

 

NOTE: If the above still doesn't resolve it, you many need to rebuild performance counters on the machine:

  1. Open an elevated instance of Command Prompt (Run As Administrator).
  2. Navigate to C:\Windows\SysWow64
  3. Run the command:
    lodctr /R

 

For more information, you can refer to MSExchangeIS Mailbox Performance monitor object is not available (© 2018 Microsoft, available at https://docs.microsoft.com, obtained on October 15, 2018).

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

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