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Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > Alert macros in SAM are not providing values

Alert macros in SAM are not providing values

Created by Chris Foley, last modified by MindTouch on Jun 23, 2016

Views: 872 Votes: 2 Revisions: 3

Overview

This article describes the issue where macros used by alert actions are not translated to their actual values when receiving an alert email for an application or component in SAM.

Environment

  • All SAM versions
  • All Windows versions

Cause 

This occurs because component-specific macros are being used within an alert based on applications.

The scenario that could lead to the following

1. Alert is created and set to I want to alert on Components.

2. Actions are configured with component-specific macros.

3. Alert is reconfigured and set to I want to alert on Applications.

Resolution

Perform either of the following options

  • Reset the alert to I want to alert on Components and re-enter the Trigger Conditions.
  • Edit the Trigger/Reset Conditions to remove all macros from all fields and re-enter them using the Insert Variable button, which will only list macros that should be used for the alert.

 

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