Submit a ticketCall us

AnnouncementsAre You “Flying Blind?”

When it comes to your complex IT infrastructure, you want to ensure you have a good grasp of what’s going on to avoid any fire drills that result from guesswork. Read our white paper to learn how proactively monitoring your IT environment can help your organization while giving you peace of mind.

Get your free white paper.

Home > Success Center > Server & Application Monitor (SAM) > SAM - Knowledgebase Articles > Agent Plugin Status is always in Installing State during Deployment

Agent Plugin Status is always in Installing State during Deployment

Updated November 3rd, 2016

Overview

This article provides brief information and steps to resolve the issue when the Agent plugin deployment is always showing that the agent plugin status is in Installing state.

Environment

SAM version 6.2

 

Cause

The issue is caused when when deploying the agent or agent plugins over very low bandwidth links, the agent plugins can take a very long time to download causing the agent to timeout and try again. This process repeats indefinitely.

Resolution

Install both x64 and x86 versions of Visual C++ Redistributable and .Net framework 4.0 separately from the Agent. This will ensure that the agent plugin dependencies are satisfied without the need to be downloaded from the Agent Management Service. 
 

 

Last modified

Tags

Classifications

Public