Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Server & Application Monitor (SAM) > Job Engine Worker Processes consuming 100% CPU

Job Engine Worker Processes consuming 100% CPU

Created by Tiarnan Stacke, last modified by MindTouch on Jun 23, 2016

Views: 78 Votes: 3 Revisions: 5

Updated June 8, 2016

Overview

An issue is occurring where a single Job Engine v2 Worker Process is consuming all available CPU.

 

In the command line section in the Task Manager, it's observed that it's a Solarwinds.APM.Probes Worker Process.

 

Relevant errors for this issue can be found in the following:

C:\ProgramData\Solarwinds\JobEngine.v2

WARN    Solarwinds.JobEngine.PerformanceCounters - Failed to ensure peformance counters
        are registered. Performance counter may not be available. 
        Error message: "The configuraiton registry key is invalid"

 

C:\ProgramData\Solarwinds\Logs\APM\SolarWinds.APM.Probes_[xxxx]

unable to get lock initialization of performance counters

Environment

Sam version 6.2.3 and later

 

Cause 

This issue occurs due to a broken performance counters for the Job Engine Service.

Resolution

To resolve this, rebuilt the Performance Counters on the Polling Engine which is having issue.

 

Steps on how to perform this task can be found in the following:
    Performance Counters are not working or missing in PerfMon

 

 

 

Last modified
02:56, 23 Jun 2016

Tags

Classifications

Public