Submit a ticketCall us

Training Class Getting Started with SolarWinds Backup - February 28

This course offers customers an introduction to SolarWinds Backup, focusing on configuring the backup technology, taking backups, data restoration and data security. It is a great primer and will get you up to speed quickly on SolarWinds Backup.
Register for class.

Home > Success Center > Server & Application Monitor (SAM) > Interfaces are not displayed in List Resources of a WMI node with SAM installed

Interfaces are not displayed in List Resources of a WMI node with SAM installed

Updated May 31, 2017

Overview

Interfaces are not displayed in List Resources of a WMI polled node when SAM is installed.

Note: SAM is a requirement for WMI interface polling. 

Environment

All SAM versions

Cause 

There is an issue with the additional polling engine, or the data not being available on the polled node.

Resolution

Check that the additional polling engine has SAM installed

  1. Establish a remote connection to the additional polling engine.
  2. Go to the Control Panel > Programs and Features, or Run > enter appwiz.cpl.
  3. Check if SolarWinds Server & Application Monitor vx.x is installed and make sure that it is the same version with the primary server.,
  4. If it is not installed, use the Scalability Engines Installer (v6.3+). For previous releases, the installer is available from the Customer Portal.

Check the source data on the target node

  1. Establish a remote connection to the polling engine that polls the target node.
  2. Cick Run, enter wbemtest, and then click Connect.
  3. Enter the following parameters:
    • Namespace: \\IPofTarget\root\cimv2
    • User: DOMAIN\Username
    • Password: ********
    • Authority: Leave this Blank
  4. Click Connect, and then run the following query:
SELECTName,ConfigManagerErrorCode,InterfaceIndex,MACAddress,Speed,AdapterTypeId,NetConnectionID,NetEnabled FROM Win32_NetworkAdapter

       If the interfaces are available and the statistics are missing, run the following query:

SELECT
Name, BytesReceivedPerSec, PacketsReceivedUnicastPerSec, PacketsReceivedNonUnicastPerSec, BytesSentPerSec, PacketsSentUnicastPerSec, PacketsSentNonUnicastPerSec
FROM Win32_PerfRawData_Tcpip_NetworkInterface

 

See the WMI Network Interface monitoring does not collect and report statistics in instances where NIC teaming is enabled article if there are still issue with the polling of NIC statistics.

 

Last modified

Tags

Classifications

Public