Submit a ticketCall us

AnnouncementsWeb Help Desk Integrations eCourse

Looking to reduce response times? Sign up for our eCourse to learn how integrating Web Help Desk with Dameware Remote Support, Network Configuration Manager, Network Performance Monitor, and Server & Application Monitor can improve communication efficiencies.

Register here.

Home > Success Center > Server & Application Monitor (SAM) > IBM Informix Application returns an error for both the 32-bit and 64-bit ODBC driver

IBM Informix Application returns an error for both the 32-bit and 64-bit ODBC driver

Created by Interspire Import, last modified by Su-Lyn Rosenberry-ret on Jul 10, 2017

Views: 1,473 Votes: 0 Revisions: 9

Overview

This article provides brief information and steps to resolve the issue when the IBM Informix Application returns an error for both the 32-bit and 64-bit ODBC driver.

Environment

All SAM versions

Cause

In the 64-bit version of the Windows operating system, there are two different Windows\System32 directories: 

  • System32 for 64-bit applications
  • SysWOW64 for 32-bit applciations

Both directories contain odbcad32.exe. The first is used for 64-bit applications, the second for 32-bit applications. This program is called from Control Panel > Administrative Tools > ODBC Data source.

Resolution

For the IBM Informix Application to run, Informix Drivers from the client SDK must be installed.

Once installed on the 64-bit version of Windows, the Informix 64-bit drivers only get registered for the 64-bit version of odbcad32.exe, located in the Windows\system32directory, and not the 32-bit version of odbcad32.exe, located in the SysWOW64 directory. 


If APM is installed on a 64-bit version of Windows, select 64-bit mode for the monitor.

 

Last modified

Tags

Classifications

Public