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Home > Success Center > Server & Application Monitor (SAM) > HTTPS monitors are failing

HTTPS monitors are failing

Created by William Muhle, last modified by MindTouch on Jun 23, 2016

Views: 156 Votes: 0 Revisions: 3

Overview

This article describes the issue when HTTP monitors are showing up as failed. In the application monitor debug logs, this error message appears::

ERROR SolarWinds.APM.Probes.HTTP.HttpProbeBase`1 - WebException caught.
System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.Management.Automation.PSInvalidOperationException: There is no Runspace available to run scripts in this thread. You can provide one in the DefaultRunspace property of the System.Management.Automation.Runspaces.Runspace type

Environment

All versions of SAM running a HTTPS Monitor

 

Cause 

This issue occurs due to the 32 bit job engine worker process is being overloaded.

Resolution

  1. Open the Edit Application Monitor for the monitor that contains the component monitors.
  2. Expand the advanced tab that is found in the edit page. There is an option to run the monitor as a x86 or a x64 bit job.  
  3. Change this job to a x64 bit job.
  4. Scroll down to the bottom, click submit, and then bounce the services.

Once finished, give it time to poll and it should work properly now. 

 

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