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Home > Success Center > Server & Application Monitor (SAM) > Error: The I/O operation has been aborted because of either a thread exit or an application request

Error: The I/O operation has been aborted because of either a thread exit or an application request

Overview

This article provides brief information and steps to resolve the following error:

The I/O operation has been aborted because of either a thread exit or an application request.

Environment

All SAM versions

Cause

The issue is caused by WinRM session running out of memory.

By default, each session is limited to 150MB. For large organizations, this may not be sufficient to run some of the queries utilized by AppInsight for Exchange.

Resolution

Modify the WinRM settings on both the Orion and remote servers by running the following command from an elevated Command Prompt (administrator):

winrm set winrm/config/winrs @{MaxMemoryPerShellMB="<size>"}</size>

Verify the setting by running the following:

winrm get winrm/config/winrs
Last modified
22:32, 30 Nov 2016

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