Submit a ticketCall us

Solarwinds & Cisco Live! Barcelona
Join us from the 29th of January to the 2nd of February at Cisco Live 2018 in Barcelona, where we will continue to show how monitoring the network with SolarWinds will keep you ahead of the game. At our booth (WEP 1A), we will demonstrate how SolarWinds network solutions can help. As a bonus, we are also hosting a pre-event webinar - Blame the Network, Hybrid IT Edition with our SolarWinds Head Geek™, Patrick Hubbard on January 24th - GMT (UTC+0): 10:00 a.m. to 11:00 a.m. There's still time to RSVP.

Home > Success Center > Server & Application Monitor (SAM) > Error: The I/O operation has been aborted because of either a thread exit or an application request

Error: The I/O operation has been aborted because of either a thread exit or an application request

Overview

This article provides brief information and steps to resolve the following error:

The I/O operation has been aborted because of either a thread exit or an application request.

Environment

All SAM versions

Cause

The issue is caused by WinRM session running out of memory.

By default, each session is limited to 150MB. For large organizations, this may not be sufficient to run some of the queries utilized by AppInsight for Exchange.

Resolution

Modify the WinRM settings on both the Orion and remote servers by running the following command from an elevated Command Prompt (administrator):

winrm set winrm/config/winrs @{MaxMemoryPerShellMB="<size>"}</size>

Verify the setting by running the following:

winrm get winrm/config/winrs
Last modified

Tags

Classifications

Public