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Home > Success Center > Server & Application Monitor (SAM) > Asset Inventory of SAM is not providing Manufacturer, Model or Serial Number

Asset Inventory of SAM is not providing Manufacturer, Model or Serial Number

Created by Chris Foley, last modified by MindTouch on Jun 23, 2016

Views: 1,563 Votes: 1 Revisions: 4

Overview

When looking at a Node's Asset Inventory information, the Manufacturer, Model or Serial Number information are not provided.  All the required OIDs or WMI classes for HP, IBM or Dell are returning information using SNMPWalk or Wbemtest.

Environment

SAM 5.x or later

Cause 

This is because the Asset Inventory was discovered and added before the required enterprise-specific agents were installed. To verify this, run the following query against the Orion Database:

 

SELECT PollingDescriptionName  FROM [dbo].[AssetInventory_Polling] where NodeID = '{ID}'  

 

Note: Replace {ID} with internal ID of Node.

 

The possible values are:

 

-ServerSNMP
-ServerSNMPDell
-ServerSNMPHP
-ServerSNMPIBM
-VMwareCIM
-VMwareCIMDell
-VMwareCIMHP
-VMwareCIMIBM
-WindowsServer2003WMI
-WindowsServerDell2003WMI
-WindowsServerDellWMI
-WindowsServerHP2003WMI
-WindowsServerHPWMI
-WindowsServerIBM2003WMI
-WindowsServerIBMWMI
-WindowsServerWMI

 

If the resulting PollingDescriptionName value does not contain 'IBM', 'Dell' or 'HP', Asset Inventory needs to be rediscovered on the system.

Resolution

  1. Go to Settings > Manage Nodes.
  2. Select the Node in question and click List Resources.
  3. Uncheck Asset Inventory.
  4. Click Submit.
  5. Go back to Settings > Manage Nodes.
  6. Select the Node in question and click List Resources.
  7. Recheck Asset Inventory.
  8. Click Submit.

 

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