Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Server & Application Monitor (SAM) > AppInsight for IIS - Polling produces error: Unexpected token

AppInsight for IIS - Polling produces error: Unexpected token

Created by Tiarnan Stacke, last modified by Caroline Juszczak on May 04, 2017

Views: 26 Votes: 0 Revisions: 4

Updated

Overview

AppInsight for IIS polling produces an error similar to the following

Unexpected token 'xXBN*' $uri = 'https://172.22.90.225:5986/wsman/'
$uriTemplate = '' $configurationName = 'Microsoft.PowerShell'
$retryConnectUsingFdqn = $False
$macroMissingWindowsCredentials = 'IisPowerShellMissingWindowsCredentials'
$macroUnableConnect = 'IisUnableConnectWinRmWindows'
$macroSessionsDepleted = 'IisSessionsDepletedWinRmWindows'
$macroSessionClosed = 'IisSessionClosedWinRmWindows'
$sessWsman = SwiGetPsSession $ip $login $uri $password

Environment

Server & Application Monitor 6.2+

Cause 

A single quote is is not a valid character to be used in the Username/Password of the credentials used for polling.

Resolution

Change the credentials being used for polling to not use the special character single quote (').

 

Last modified
10:45, 4 May 2017

Tags

Classifications

Public