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Home > Success Center > Server & Application Monitor (SAM) > AppInsight for Exchange: Missing performance counters

AppInsight for Exchange: Missing performance counters

Overview

AppInsight for Exchange is missing a performance counter or are not loading properly.

Environment

  • All SAM versions
  • Microsoft Exchange 2013

Resolution

Note: The files provided in this article are valid for Microsoft Exchange 2013 (V15). The missing files will depend on the missing category. Find the appropriate tuple of (missing) files in the DVD:\Setup\Perf folder.

  1. Close all PerfMon windows.
  2. Copy the missing performance counter files from the source DVD to C:\Program Files\Microsoft\Exchange Server\V15\Setup\Perf.
    Files include:
    IndexAgentPerfCounters.h
    IndexAgentPerfCounts.ini
    IndexAgentPerfCounters.xml
  3. Go to Start > Control Panel > Administrative Tools > right click Windows PowerShell and choose Run as administrator.
  4. Run the following command:
    New-PerfCounters -DefinitionFileName "C:\Program Files\Microsoft\Exchange Server\V15\Setup\Perf\IndexAgentPerfCounters.xml"
  5. Check the Windows Application Log to verify that the performance counters are loaded properly.
  6. Upon verification, click Poll Now on the Orion Web Console.
  7. After a few minutes, the counter should no longer be in Unknown state.

For more information, you can refer to MSExchangeIS Mailbox Performance monitor object is not available.

Cause

This is caused by broken or missing performance counters.

Last modified
11:44, 30 Nov 2016

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