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Home > Success Center > Server & Application Monitor (SAM) > AppInsight Exchange databases stop working after Cumulative Update 11

AppInsight Exchange databases stop working after Cumulative Update 11

Created by Kevin Sperrazza, last modified by Melanie Boyd on Jan 05, 2017

Views: 65 Votes: 3 Revisions: 8

Overview

After updating to Exchange Cumulative Update 11 (CU11), the database and mailbox information from AppInsight For Exchange stops populating data.

Environment

  • SAM 6.2.1
  • SAM 6.2.2
  • SAM 6.2.3
  • Exchange 2013 CU11

Cause 

The comandlet Get-MailboxDatabaseCopyStatus is behaving differently after the upgrade. This causes the current scripts to not work properly and no longer get data.

Resolution

This issue has been resolved in SAM 6.2.3 hotfix 1.

Please upgrade to this version and download this from your customer portal:

SolarWinds® Server & Application Monitor (SAM) 6.2.3 Hotfix 1
===================================================================================

This hotfix corrects an issue where AppInsight for Exchange does not correctly poll
all database copies correctly from a system hosting Microsoft® Exchange Server®
2013 Cumulative Update 11 (CU11).

This hotfix applies to a SAM deployment connected to a server running Exchange
Server 2013 CU11 with a database availability group (DAG) that includes at least
two databases.

This hotfix contains the following script:

* AppInsightForExchangeDoesntPollAllDatabases.sql

This script applies Hotfix 1 on your SolarWinds Orion database.

Before you install this hotfix, ensure that:

* Each database includes an active copy on different servers.

* AppInsight for Exchange is assigned to a mailbox (MBX) server with an active
copy of the server.

* The AppInsight for Exchange Details page assigned to the MBX server does not
display all active database copies in the web console. These database copies
would normally appear in the Mailbox Database Status resource.

Do not install this hotfix if any of the above conditions are not true.

-----------------------------------------------------------------------------------
Install Hotfix 1

1. Back up your SolarWinds Orion database.

2. Run the attached script on your SolarWinds Orion database.

You can use Microsoft SQL Server Management Studio to execute this script.

3. Verify that the AppInsight for Exchange Details page assigned to the MBX
server displays all active database copies in the web console.

-----------------------------------------------------------------------------------
Uninstall Hotfix 1

This hotfix executes a script on your SolarWinds Orion database that cannot be
uninstalled.

For assistance, contact SolarWinds Customer Support using one of the
following methods:
 

* Submit a ticket at customerportal.solarwinds.com/support/submit-a-ticket
* Phone 866.530.8040, Option 3
* Phone 512.682.9300

 

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