Home > Success Center > Server & Application Monitor (SAM) > Agent plugin does not poll when installed on a machine with an expired Orion license

Agent plugin does not poll when installed on a machine with an expired Orion license

Overview

The SAM Agent Plugin does not poll after successfully installing the client agent. The following error message appears in the Agent Log (C:\ProgramData\Solarwinds\Logs_Agent\APM\SolarWinds.APM.Probes_[xxxx].log):

2015-09-17 19:13:32,608 STP SmartThreadPool Thread #0 [A(null)] [C(null)] ERROR SolarWinds.APM.Probes.LicenseValidator - License validation failed for SolarWinds.APM.Probes. Check if you run in correct mode (FULL vs. POLLER) and if correct registry values are set.
SolarWinds.APM.Common.Licensing.ApmLicenseException: License is expired or not available. ---> SolarWinds.Licensing.Framework.SolarWindsLicensingException: License is expired or not available
at SolarWinds.APM.Common.Licensing.FrameworkLicensing.get_IsEvaluationOrTempKey()
at SolarWinds.APM.Common.Licensing.LicenseHelper.ValidateLicense(ILicensing licensing, LicensedModule module)
— End of inner exception stack trace —
at SolarWinds.APM.Common.Licensing.LicenseHelper.ValidateLicense(ILicensing licensing, LicensedModule module)
at SolarWinds.APM.Probes.LicenseValidator.VerifyLicense()

Environment

SAM 6.2.2

Resolution

Contact SolarWinds Customer Support and request to have the Evaluation license removed.

Cause 

The new plugin will not poll when installed on a machine where the Evaluation license had expired

 

You must to post a comment.
Last modified
00:46, 24 Nov 2016

Tags

Classifications

Public