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Home > Success Center > Server & Application Monitor (SAM) > Add node results in ContractFilter error

Add node results in ContractFilter error

Updated March 22, 2017

Overview

When adding a node, the following error is returned after clicking OK, Add Node on the last step: 

 

The message with Action 'http://schemas.solarwinds.com/2008/C...thFaultContact' cannot be processed at the receiver due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that the sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).

 

Environment

  • SAM 6.4
  • All Windows versions

 

Cause 

Main install has been upgraded from SAM 6.3 to 6.4, however additional polling engines were not. 

As a result, adding node to additional polling engines results in error after clicking OK, Add Node on the last step. 

Adding a node to Primary Poller works fine.

 

Resolution

  1. Upgrade the additional polling engine to the same version as the main Orion installation.
  2. Go to Settings > All Settings > Polling Engines to ensure they are all on the same platform version.

 

 

 

Last modified
17:47, 21 Mar 2017

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