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Home > Success Center > Serv-U Managed File Transfer & Serv-U FTP Server > Server sent passive reply with unroutable address

Server sent passive reply with unroutable address

Updated March 5th, 2017

Overview

FileZilla users are unable to list to directory and having a connection error

Server sent passive reply with unroutable address.

Environment

All Serv-U versions with below supported operating system: 

  • Windows Vista/7/8, Server 2008/2012 
  • Windows 2000/XP, Server 2000/2003 
  • Linux 

Cause 

FileZilla has updated their FTP client and FTP over TLS is now used by default and this result to clients unable to connect to their server from the outside network.

Resolution

Make sure that you properly set up for FTP over TLS/SSL Explicit and passive ports are allowed on the firewall and set on Serv-U.

 

Serv-U settings at: Global Limits & Settings > Settings, scroll down to Network Settings:

  1. Auto-configure firewall through UPnP is not checked – leave this unchecked
  2. Packet time-out is 300 seconds – leave as is.
  3. and PASV port Range is 0 – 0. – set to 50,000-50,009 and port forward this ports to your router.

 

By doing the above, we are configuring the file transfer traffic to be routed through the router and directly to Serv-U through “Port Forwarding”.

 

  1. If you are still unable to connect, the next step is to configure the IP address Serv-U uses for its response to the PASV command so that it uses the actual IP address and not the internal IP that Serv-U sees. But this should be automatically done by their NAT device.

 

To do this, follow the steps below.

  1. Navigate to Domain Details | Listeners
  2. Select your FTP/FTPS listener(s) and click Edit
  3. Enter the external IP address (or domain name if applicable) of your internet connection in the PASV IP Address Or Domain Name field. If you are using Serv-U with a dynamic IP address, leave this field blank.

 

If a this point you are still unable to connect, try disabling the "Block FTP_Bounce and FXP" option - this has been known to cause issues for some clients. To do this, follow the steps below:

  • Navigate to Server Limits and Settings | FTP Settings
  • Select Global Properties. If this is not available, first select Use Custom Settings to gain access to it
  • Navigate to the Advanced Options tab and make sure that "Block FTP_Bounce and FXP" option is unchecked (which it is by default)

 

  

Reference: Serv-U Firewall Rules (Also Router Rules)

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

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