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Home > Success Center > Patch Manager > WSUS patch causes access denied errors in Patch Manager

WSUS patch causes access denied errors in Patch Manager

Overview

The following error occurs when you try to access any software publishing tasks in the Patch Manager console, and you are not able to connect to the update server.

Source: EminentWare.UI.MMC.SoftwarePublishing
Exception occurred at 7/1/2016 1:27:26 PM: Access is denied
DataPortal_Fetch method call failed
DataPortal.Fetch failed
Stack: at Microsoft.UpdateServices.Internal.UtilClassFactory.CreateInstance(Type type, Object[] args)
at Microsoft.UpdateServices.Internal.SetupInfo.GetInstallDirectory()
at Microsoft.UpdateServices.Administration.Internal.UpdateServicesPackage.Verify(String packageFile)
at Microsoft.UpdateServices.Administration.Internal.UpdateServicesPackage.Save(String packageFile)
at Microsoft.UpdateServices.Administration.Internal.UpdateServicesPackage.Verify()
at Microsoft.UpdateServices.Administration.SoftwareDistributionPackage..ctor(IXPathNavigable sdpNode)
at EminentWare.BusinessObjectLayer.SoftwarePackage.SoftwarePackage.Read(SafeDataReader dr)
at EminentWare.BusinessObjectLayer.SoftwarePackage.SoftwarePackageList.DataPortal_Fetch(Criteria criteria)
at Csla.MethodCaller.CallMethod(Object obj, MethodInfo info, Object[] parameters)
at Csla.MethodCaller.CallMethod(Object obj, String method, Object[] parameters)
at Csla.Server.SimpleDataPortal.Fetch(Type objectType, Object criteria, DataPortalContext context)
at EminentWare.UI.MMC.SoftwarePublishing.SoftwarePackagesViewControl.RefreshData(SoftwarePackagesScopeNode node, SoftwarePackageList list, Exception ex)

Environment

  • All Patch Manager versions
  • All WSUS versions

Cause

Patch Manager alters permissions on the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup registry key when it is installed alongside a WSUS server. This error occurs whenever those permissions are reset, typically when WSUS is reinstalled. However, Microsoft update KB2720211 (© 2012 Microsoft, available at https://support.microsoft.com, obtained on August 15, 2015) also resets these permissions, causing the same issue. 

Resolution

Ensure the local Users group has read access for the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup registry key on all WSUS servers collocated with Patch Manager:

  1. Open Registry Editor (regedit).
  2. Select HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup.
  3. In the Edit menu, select Permissions.
  4. In the Permissions for Setup window, select the local Users group.
  5. Under Permissions for Users, select Read in the Allow column.
  6. Click OK.

 

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