Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Patch Manager > Unable to deploy WMI Providers - Input string was not in a correct format

Unable to deploy WMI Providers - Input string was not in a correct format

Created by Erica Gill, last modified by MindTouch on Jun 23, 2016

Views: 27 Votes: 0 Revisions: 4

Overview

This article describes an issue where Patch Manager is unable to deploy the WMI Providers, reporting an error:

 

Details: Although we successfully connected to Some_Client_Computer_FQDN, we were unable to install the EminentWare WMI providers. 
Detail: Input string was not in a correct format.

Environment

Patch Manager 2.1.1.2005 SR2 and earlier 

Cause 

There may be files in the same folder as the WMI providers which are being picked up as valid WMI providers installers however which are invalid. 

Resolution

  1. Open the folder where Patch Manager is installed.
  2. Browse to the subfolders Server\packages\EminentWare.
  3. Confirm the folder only contains a version of the wmiproviders_X.X.XXX.exe, where X.X.XXX is the version of Patch Manager installed and a file called wmirdist.msi.
  4. If there are other files in the folder, move them and verify that the issue clears. 

 

Last modified
01:20, 23 Jun 2016

Tags

Classifications

Public