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Home > Success Center > Patch Manager > Unable to connect to clients using WMI or other Client Connectivity issues

Unable to connect to clients using WMI or other Client Connectivity issues

Created by Brandon Painter, last modified by MindTouch on Jun 23, 2016

Views: 366 Votes: 1 Revisions: 13

Overview

If you are unable to connect with WMI to your clients, you will want to try to install the agent using the Remote Installer Service or with a WSUS Package.

Environment

  • All Patch Manager versions

Note: Your environment does not allow connections over WMI to your client machines

Cause 

Your clients are not able to communicate over WMI with Patch Manager due to environmental restrictions.

Resolution

  1. In Managed Computers or in Update Services > WSUS > Computers and Groups > All Computers, highlight the computer you want to push the agent to and click Deploy Client Components in the Actions pane.
  2. Follow the prompts to install the Agent either with the Remote Installer Services or with a WSUS Package.
    1. If you choose the Remote Installer Services, it will launch a task to install the agent with Patch Manager.
    2. If you use the WSUS Package, you will need to go to Administration and Reporting > Software Publishing > Solarwinds, Inc. and find the Solarwinds Patch Manager Agent package. You can then publish that package to your WSUS. Once it's published, you can approve it to your groups.
  3. You can also get the installer from the directory identified in Administration and Reporting > Software Publishing > Solarwinds, Inc. Select the package and in the description field on the bottom half of the middle pane will be a package location. You can copy this to any system and run the installer. 
    1. Follow the prompts to install the Complete version click next
    2. Input the Primary Application Server (PAS) and click next.
    3. If prompted you may need to input the PAS again and an account that is an Admin on the Patch Manager server.

 

 

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