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Home > Success Center > Patch Manager > Troubleshoot timeout errors in Patch Manager

Troubleshoot timeout errors in Patch Manager

Created by Seamus.Enright, last modified by Justin Rouviere on Jun 08, 2017

Views: 70 Votes: 0 Revisions: 10

Overview

When you encounter timeout errors while executing update services tasks, they are generally indicative of an unhealthy update server. The procedures in this article will help troubleshoot these errors and recommend ways to keep your update servers healthy.

Environment

Patch Manager

Cause

Timeout issues are generally due to one or more of the following conditions:

  • There is a high number of updates on the update server.
  • There is a high number of approvals on the update server.
  • The file system hosting the SUSDB database files is severely fragmented.
  • The SUSDB database needs re-indexing.

Resolution

Review the updates on the update server and remove approvals for superseded updates reported as 100% Not Applicable.

Create a custom view in the Patch Manager console for these types of updates

  1. In the left pane of the Patch Manager console, expand Enterprise > Update Services, and then expand your update server.
  2. Select Updates under the WSUS server that is having the issue.
  3. In the Actions pane (right), click New Update View.
  4. Under Step 1, the Select Properties window will open, select Updates have a specific approval and installation status.
  5. Under Step 2, edit the properties (click on an underlined value), and then define the properties:
    1. Click approved and needed.
    2. In the Approved State field, select Approved.
    3. In the Update Status field, select Installed/Not applicable.
    4. Click OK.
  6. Under Step 3, specify the update view name and description, enter a name and description for the new view.
  7. Click OK.
  8. Back in the main Patch Manager window, select the new view that you named in the left pane.
  9. Filter the view to show only updates with superseding updates:
    1. On the Has Superseding Updates column header, click the filter icon.
    2. Clear all of the check boxes except for Yes.
    3. Click OK.
  10. Enable the Not Applicable Percentage column:
    1. In the Actions pane, click Choose Columns.
    2. In the Column Chooser window, select the Not Applicable Percentage check box.
    3. Close the Column Chooser window.
  11. Sort the view by the new column in descending order.

After you create this view, remove the approvals for all of the updates with a Not Applicable Percentage equal to 100. Investigate the rest to determine why they are not also at 100%. This view should be as empty as possible.

 

Delete Unnecessary Updates

In some cases the rules for the WSUS Server Cleanup Wizard are not comprehensive enough to delete unnecessary or declined updates.  To remove these updates manually via the Patch Manager Administrative Console, do the following:

  1. In the left pane of the Patch Manager console, expand Enterprise > Update Services, and your update server.
  2. Select the view that fits the updates best.
    NOTE:  Selecting the All Updates view will most likely cause a timeout if you have too many updates on the WSUS server.  You can right click on Updates and create a new update view to get a view specific to the updates you are trying to delete.
  3. Sort the updates to select updates you would like to remove, suggestions:
    1. Remove updates based on date.
    2. Remove updates for unused or deprecated products.
    3. Remove Drivers and Language based updates.
    4. Remove Declined updates.
      NOTE:  You will need to modify the WSUS Products and Classifications settings to prevent the re-synchronization of removed updates.  De-select products that you no longer desire to synchronize updates for.
  4. Deleting updates in this manner can take several hours.  During the course of this process you are likely to see timeouts continue from the Patch Manager and WSUS server.  As long as the task is running under Active Tasks then Patch Manager is continuing to delete the selected updates.

Run the Server Cleanup Wizard

  1. In the left pane of the Patch Manager console, expand Enterprise > Update Services, and then select your update server.
  2. In the Actions pane (right), click Server Cleanup Wizard.
  3. Complete the wizard as appropriate for your environment.

Note: If you have never run the Server Cleanup Wizard, consider running it as a multi-pass event:

  1. Select Computers not contacting the server, Expired Updates, and Superseded Updates in the first pass. This should only take a few minutes even in the worst of conditions.
  2. Select Unused updates and update revisions in the second pass. Note: It is not uncommon for this pass to take several hours. We recommend you schedule this pass as an overnight task using Patch Manager. The task may timeout if run from the WSUS console, but it will not timeout if run as a Patch Manager scheduled task.
  3. Select Unneeded update files in the third pass. This may take several minutes, depending on the practical results of the first two passes and what files are actually eligible for deletion.

 

Stop the SUSDB database service on the update server

Run a disk defragmentation on the volume hosting the database files

Restart the database service and run a database reindex

Microsoft provides a documentation on this procedure in the following section of the WSUS Operations Guide: Reindex the WSUS Database.

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

Last modified
09:48, 8 Jun 2017

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