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Home > Success Center > Patch Manager > Troubleshoot "Invalid Namespace" Errors - server or managed clients

Troubleshoot "Invalid Namespace" Errors - server or managed clients

Created by Brandon Painter, last modified by MindTouch on Jun 23, 2016

Views: 1,979 Votes: 0 Revisions: 5

Overview

Use the following procedures to troubleshoot Invalid namespace errors from either the Patch Manager server or managed clients. Basically, this error message means that the WMI Providers are not accessible by the server or not present on the clients.

Environment

All Patch Manager versions

Cause 

This error can be caused UAC interference or by missing WMI Providers.

Resolution

Procedure - Servers

Most often, Patch Manager returns the Invalid namespace error on Patch Manager servers when User Account Control (UAC) prevents the server from communicating with the WSUS server. To resolve this issue, choose one of the following options:

  • Disable UAC on the Patch Manager server
  • Use the built-in local Administrator account to communicate with your WSUS server

To set the built-in local Administrator account to communicate with the WSUS server:

  1. In the Patch Manager console, expand Patch Manager System Configuration, and then select Security and User Management.
  2. In the center pane, click the Credentials tab.
  3. If the built-in local Administrator account is not on the Credentials list, add it:
    1. Click Add Credential in the Actions pane.
    2. Enter .\administrator in the User name field.
      Note: If you have renamed the built-in local Administrator account, replace "administrator" with the custom name.
    3. Enter and confirm the password for the built-in Administrator account.
    4. Click Save.
  4. Click the Credential Rings tab.
  5. Select the Credential Ring you want to modify, and then click Credential Ring Wizard in the Actions pane.
  6. Select the built-in local Administrator account from the User Name menu, and then click Add.
  7. Click Next.
  8. Add a Computer Rule for the Patch Manager server to tell it to use the local Administrator account:
    1. On the Create or modify Credential Rules screen, click Add Rule, and then select Computer.
    2. On the Select Computer screen, select Update Services Servers in the left pane.
    3. In the center pane, select the WSUS server, and then click Add selected.
    4. Click OK.
    5. On the Select User for Credential Rule screen, select .\administrator or the appropriate custom built-in Administrator account, and then click OK.
  9. Click Finish to close the Credential and Credential Rings Rules Wizard.

Procedure - Clients

First, try disabling the Anti-Virus on the client.

Patch Manager usually returns the Invalid namespace error for managed clients when they do not have the requisite WMI Providers installed.

Note: If the Invalid namespace error contains an "Invalid Signature" message, this indicates an issue with the remote computer's root certificates store. To resolve this issue, update the root certificates store on the remote computer. For additional information, see "Invalid Signature" error when attempting configuration management tasks on remote systems.

To install WMI Providers on managed clients:

  1. Run the Computer Access Management task:
    1. In the Patch Manager console, locate and select the group to which the affected computer belongs.
    2. If you want to run the task for that group of computers, click Check and Manage Computer Connectivity in the Actions pane.
    3. If you want to run the task for a specific computer, select the computer in the center pane, and then click Check and Manage Computer Connectivity in the Actions pane.
    4. In the Computer Access Management window, select Install the WMI Providers if not already installed, and then select the applicable sub-options.
    5. Select all of the options outside of the SolarWinds WMI Providers Actionsgroup except Enable DCOM if disabled.
    6. Click OK to run the task.
  2. If the Computer Access Management task cannot install the WMI Providers remotely, see Troubleshoot "Access Denied" errors in Patch Manager.

 

 

Last modified
01:19, 23 Jun 2016

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