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Home > Success Center > Patch Manager > Systems do not reboot after an update is published to multiple system

Systems do not reboot after an update is published to multiple system

Overview

When Patch Manager is assigned a task that targets multiple managed servers, the servers do not reboot properly. 

Environment

Patch Manager 2.1 and later​

Cause

  • Update Management Wizard Functionality issue. This issue occurs because the targeted system is running the published update.
  • WMI Connectivity issue. This issue could be related to WMI connectivity issues. Installing the Patch Manager Agent on your systems allows you to connect to your systems using port 4092 instead of WMI. If WMI is working properly (test by running Computer Management on the node), the issue may be caused by the Update Management Wizard for tasks that update systems running the published update. If a system is running the update, the task will not reboot the system. If you review the Task History, the task appears to be completed, but the event logs do not record a system reboot.

Resolution

Do one of the following:

  • Address the Update Management Wizard functionality issue (workaround).
  • Address the WMI Connectivity issue.

Address the Update Management Wizard functionality Issue (workaround)

As a workaround, if you are expecting all systems to reboot, create a secondary Update Management task that has the same reboot option selected as your initial Update Management Wizard task. When completed, remove the reboot option from your initial task. 

Note the distinction between Update Management Wizard and Update Management. The Update Management Wizard will not commit the reboot if the system is up to date. Update Management will commit the reboot if you use another package as a workaround to force the systems to reboot.

When you configure the task, select the option to send an email to you as a CSV file when the task is completed. This allows you to check all system reboots to make sure they completed for all systems. 

Address the WMI connectivity issue

  1. Log in to the Patch Manager Administrator Console as an administrator.
  2. In the navigation pane, locate the system with the WMI connectivity issue.
  3. Right-click the system and select Deploy Client Components.
  4. Complete wizard to either use the remote installer services or create a WSUS package.
    If you create a WSUS package, the package will be stored at Administration and Reporting > Software Publishing > Solarwinds.
  5. Approve and publish the package to the computer groups containing the targeted systems.
    See Approving Updates for details. 
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