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Home > Success Center > Patch Manager > Servers not rebooting after updates applied and does not complete the reboot cycle

Servers not rebooting after updates applied and does not complete the reboot cycle

Created by Brandon Painter, last modified by Cory Farr on Nov 13, 2017

Views: 89 Votes: 1 Revisions: 12

Overview

The machines are not rebooting properly when assigning a task targeted at multiple systems. 

Environment

Patch Manager 2.1 and later​

Causes 

  • This could be related to WMI connectivity issues. Installing the Patch Manager Agent to your systems allows you to connect to your systems using port 4092 instead of WMI. 
  • If WMI is working properly (test by running Computer Management on the node), you may be dealing with the default functionality of the Update Management Wizard for tasks that are attempted on systems that are already up to date. If a system is already up to date, the task will not reboot the computer and will instead leave it up and running. If you review the Task History it will appear that the task finished, but you will see that the computer never rebooted on the Event Logs.

Resolutions

WMI Connectivity Issue:

  1. Find the system you are having issues with and select it in the Patch Manager console.
  2. Right-click the system and select Deploy Client Components.
  3. Follow the wizard to either use the Remote installer services or Create a WSUS Package.
  4. If you create a WSUS Package, it will create one located in:  Administration and Reporting > Software Publishing > Solarwinds.
  5. Publish the package and approve it to your computer groups that you desire to send it to. Refer to Approving Updates.

 

Update Management Wizard Functionality Issue (workaround):

  1. This issue occurs because no action was taken on the system because it was up to date. As a workaround, if you are expecting all systems to reboot, you may want to create a secondary Update Management task that has the same reboot option selected as your initial Update Management Wizard task did and remove the reboot option from your initial task. 
    NOTE: Please notice the distinction between Update Management Wizard and Update Management in the instructions above, because the Update Management Wizard will not commit the reboot no matter what, but Update Management will.
  2. Make sure that in the task you select the option to send an email to you as a .csv after the task finishes. This will allow you to check on the reboots to make sure that they were done for the entire set of computers.
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