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Home > Success Center > Patch Manager > Reports generation by querying 200 Management Servers causes timeout issues

Reports generation by querying 200 Management Servers causes timeout issues

Created by Interspire Import, last modified by MindTouch on Jun 23, 2016

Views: 22 Votes: 0 Revisions: 8

Overview

Generating reports by querying 200+ management servers causes timeout issues. 

Environment

All Patch Manager versions

Cause

Generating reports by querying 200+ management servers, many of which are on bandwidth constraints and sometimes unreliable connections, exceeds the architectural capability of any distributed database environment, including Patch Manager.

Resolution

To generate specific reports, you need to implement the following methodologies: 
  1. If you need to run a report on a single site from HQ, connect the Patch Manager Console session to the site-specific AppServer and run the report from that AppServer, which contains data for the local WSUS.
  2. If you need to run a report on the entire enterprise, connect the Patch Manager Console session to the local AppServer, and then filter the User Preference so it only connects to the local management group (which should contain a full inventory of the upstream WSUS server).
Notes:
  • You can use this methodology to run a report on a single downstream WSUS server by filtering on the WSUS servername column in the report, or
  • You can use this report to filter for a collection of WSUS servers (for example, a report on all European offices).
 
Last modified
01:17, 23 Jun 2016

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