Submit a ticketCall us

Get a crash course on Network Monitoring delivered right to your inbox
This free 7-day email course provides a primer to the philosophy, theory, and fundamental concepts involved in IT monitoring. Lessons will explain not only how to perform various monitoring tasks, but why and when you should use them. Sign up now.

Home > Success Center > Patch Manager > Patch Manager 2.1.4 system requirements

Patch Manager 2.1.4 system requirements

Updated June 6, 2016

Supports: Patch Manager 2.1.4

For additional information about requirements and configurations, see the SolarWinds Patch Manager Administrator GuideSolarWinds Patch Manager Installation Guide, and the SolarWinds Patch Manager Release Notes. Review your product release notes for the exact product requirements beyond these requirements. 

 

Hardware requirements 

The following table lists minimum hardware requirements and recommendations for your SolarWinds Patch Manager system.

HARDWARE REQUIREMENTS
CPU Speed

32- or 64-bit 2.0 GHz Dual Core or faster

Memory

4 GB (minimum)

10 GB or higher (recommended)

Hard Drive Space

20 GB or higher

SolarWinds Patch Manager may not require 10 GB of hard drive space when properly managed. SolarWinds recommends this amount to accommodate fluctuations in space requirements during product use.

Software requirements 

The following table lists minimum software requirements and recommendations for a SolarWinds Patch Manager installation.

SOFTWARE REQUIREMENTS
Operating System (Patch Manager servers and consoles)

Install the SolarWinds Patch Manager web console server on a 32- or 64-bit server running Microsoft Internet Information Services (IIS) and one of the following Microsoft® Windows Server® operating systems:

  • Windows Server 2008 R2 with SP1
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016

Additionally, SolarWinds Patch Manager supports the following Microsoft Windows® operating systems for evaluation purposes:

  • Windows 7
  • Windows 7 SP1
  • Windows 8
  • Windows 8.1
  • Windows 10
Operating System (managed clients)

SolarWinds Patch Manager manages 32- or 64-bit computers running any of the following Microsoft operating systems:

  • Windows XP Professional SP3 or later
  • Windows Vista Business, Enterprise, or Ultimate SP2 or later
  • Windows 7 Professional, Enterprise, or Ultimate
  • Windows 8
  • Windows 8.1
  • Windows 10
  • Windows Server 2003 SP2 or later
  • Windows Server 2003 R2 SP2 or later
  • Windows Server 2008 SP2 or later
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
Operating System (web console)

Install the SolarWinds Patch Manager web console on a 32- or 64-bit server running IIS and one of the following operating systems:

  • Windows Server 2008 R2 with SP1
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016

Additionally, SolarWinds Patch Manager supports the following operating systems for evaluation purposes:

  • Windows 7
  • Windows 7 SP1
  • Windows 8
  • Windows 8.1
  • Windows 10
Internet Browser (web console)

The SolarWinds Patch Manager web console is compatible with the following web browsers:

  • IE11, Edge (Spartan)
  • Firefox - two most recent versions at the time of shipping
  • Chrome - two most recent versions at the time of shipping
  • IE6, IE7, IE8, IE9, IE10 and other non-supported browsers are not supported but are not blocked.
  • Safari - latest version
Windows Server Update Services
(WSUS)

SolarWinds Patch Manager supports WSUS servers running the following versions:

  • WSUS 3.0 SP2 or later with Microsoft KB2734608 applied
  • WSUS 6.0 on a server running Windows Server 2012
  • WSUS 6.2 on a server running Windows Server 2012
  • WSUS 6.3 on a server running Windows Server 2012 R2
  • WSUS 10.0 on a server running Windows Server 2016
System Center Configuration Manager (SCCM)
(if applicable)

SolarWinds Patch Manager supports SCCM servers running the following versions:

  • SCCM 2007 SP2 or later
  • SCCM 2012
  • SCCM 2012 R2
  • SCCM 1511
  • SCCM 1602
  • SCCM 1606
  • SCCM 1610

Install SCCM on the server before you install SolarWinds Patch Manager.

Visual C++ Runtime
  • Microsoft Visual C++® Secure Runtime 9.0 SP1
  • Visual C++ 2008 Redistributable (32- and 64-bit)
  • Visual C++ 2010 Redistributable (32- and 64-bit)
  • Visual C++ 2012 Redistributable (32- and 64-bit)
  • Visual C++ 2013 Redistributable (32- and 64-bit)
 ​​​​​

SolarWinds Patch Manager automatically installs this software when required.

Web Server (web console server) Microsoft IIS 6.0 or later
.NET Framework
  • Version 3.5 for the SolarWinds Patch Manager server
  • Version 4.5 for the Orion Additional Web Server and Orion server
Internet Access

Install SolarWinds Patch Manager on a server that can access the following sites:

SQL database requirements 

Your product and your SolarWinds Orion database should use separate servers.

Database

SolarWinds Patch Manager is compatible with Microsoft SQL Server® instances running the following versions:

  • SQL Server 2008
  • SQL Server 2008 R2
  • SQL Server 2008 R2 SP1
  • SQL Server 2008 R2 SP2
  • SQL Server 2008 R2 SP3
  • SQL Server 2008 SP1
  • SQL Server 2008 SP2
  • SQL Server 2008 SP3
  • SQL Server 2008 SP4
  • SQL Server 2012
  • SQL Server 2012 SP1
  • SQL Server 2012 SP2
  • SQL Server 2012 SP3
  • SQL Server 2014
  • SQL Server 2014 SP1
  • SQL Server 2016

Server port requirements

Ports

The server and console components use port 4092 TCP.

Servers communicate with managed computers using the following ports:

  • 135 TCP
  • 445 TCP
  • Dynamic ports 1024 to 65536 (varies by operating system)

The SolarWinds Patch Manager web console server uses the following ports:

  • 8787 TCP
  • 17777 TCP

 

Last modified
09:12, 6 Jun 2017

Tags

Classifications

Public