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Home > Success Center > Patch Manager > Orion Web Console error: Incorrect Patch Manager version

Orion Web Console error: Incorrect Patch Manager version

Created by Zaquan Henry, last modified by Aileen de Lara_ret on Mar 26, 2017

Views: 59 Votes: 1 Revisions: 9

Updated: March 14, 2017

Overview

This article provides brief information and steps to resolve the issue when the Orion Web console receives a notification that Patch Manager has the wrong version.

The following notification displays:

"The Patch Manager Server version (version number) is greater than the Patch Manager console version (version number) and may not be compatible."

In this notification, the Patch Manager Server version is the version of the Patch Manager Primary Application Server and the Patch Manager console version is the version the Web Console is using.

 

 

Environment

  • All Orion Core products
  • Patch Manager version 1.8 and later

Cause 

The error occurs due to any of the following:

  • There is a version mismatch between the Web Console and Patch Manager.
  • An update was deployed incorrectly. 
  • A hotfix or upgrade is installed on the Patch Manager Console or an automation server but not on the Web Console.

 

In this notification the Patch Manager Server version is the version of the Patch Manager Primary Application Server and the Patch Manager console version is the version the Web Console is using.

Resolution

 

Check the versions in use:

  1. Open Windows Programs and Features through the Windows Control Panel.
  2. Find SolarWinds Patch Manager.
  3. Compare the versions on each server.

 

Install the recently applied hotfix or update to both servers:

  1. Go to the Orion Server.
  2. Run the installer or update file. 

Note: The top two boxes in the Install Wizard should be cleared to ensure only the Web Console updates. 

 

If the version mismatch continues and the Patch Manager version is version 2.1 or earlier please:

  1. Backup %ProgramFiles(x86)%\SolarWinds\Orion\Information Service\2\EminentWare.BusinessObjects.dll.
  2. Stop the SolarWinds Information Service on the Web Console server (This will stop the Web Console functioning correctly while it is stopped).
  3. Copy %ProgramFiles%\SolarWinds\Patch Manager\Server\EminentWare.BusinessObjects.dll from the PAS machine to the Web Console server, into %ProgramFiles(x86)%\SolarWinds\Orion\Information Service\2.0. 
  4. Restart the SolarWinds Information Service and confirm if the mismatch continues.

 

Last modified
17:47, 26 Mar 2017

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