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Home > Success Center > Patch Manager > Not able to synchronize packages - Synchronization Tasks not created

Not able to synchronize packages - Synchronization Tasks not created

Created by Justin Rouviere, last modified by MindTouch on Jun 23, 2016

Views: 25 Votes: 1 Revisions: 6

Updated June 8, 2016

Overview

Catalog Synchronization is not happening on the specified schedule and when selecting Synchronize Now no synchronization tasks are created in the Software Publishing view.

Environment

  • All versions of Patch Manager

 

Cause 

Corrupt information in the database.

To help diagnose this issue look for two things:

  1. When clicking "Synchronize Now" in the Action bar for Software Publishing no tasks are spawned.
  2. When reviewing the logs (default path:  C:\ProgramData\SolarWinds\PM\Log) review the EminentWare.DataGrid.Service logs in the EminentWare.DataGrid.Service folder and look for the following error:

 

2016/05/16 17:05:02:563 PID: 4228 TID:  3448 [ERROR] DownloadManager::CheckForInitialized() failed. Message: DataPortal.Update failed
 

 

Resolution

  1. Connect to the database directly via Microsoft SQL Server Management Studio.
  2. Create a New Query via the New Query button on the toolbar or File -> New -> Query with existing connection.
  3. Run the following Query:
    1. SELECT *
        FROM [EminentWare].[dbo].[ewdgsprops]
        Where [propkey] = 'ewupdate_password' OR [propkey] = 'ewupdate_username';
      
  4. In the Results tab right click on the information and select Save Results As to create a backup of the information.
  5. Delete the ewupdate_password information:
    1. Delete
        FROM [EminentWare].[dbo].[ewdgsprops]
        Where [propkey] = 'ewupdate_password';
      
  6. Restart the EminentWare Data Grid Server service.
  7. Launch the Patch Manager console.
  8. Expand Administration and Reporting.
  9. Select Software Publshing.
  10. Click Synchronize now.
  11. The tasks should now create and you should see them as Running in the Result column.
  12. If you do not see the tasks start or if the Result is failed after the synchronization is complete, contact Support.

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third party customers. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any. 

 

 

Last modified
01:06, 23 Jun 2016

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