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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Wake on LAN task fails

Wake on LAN task fails

Overview

When you run the Wake On LAN (WOL) task for a managed computer, the following error message displays in the Patch Manager Console:

Failed to retrieve MAC address for target

Environment

All Patch Manager versions

Cause 

Patch Manager could not retrieve the MAC address of each managed computer because the network discovery task for the subnet failed.

Resolution

  1. Log in to the Patch Manager Admin Console as an administrator.
  2. In the navigation pane,, expand Patch Manager System Configuration > Managed Groups and select Managed Enterprise. 
  3. Click the Discover Subnets tab.
  4. In the Actions pane, click Add Subnet.
  5. Enter the IP Address and Subnet Mask of the workstation.

    The Starting Address and Ending Address fields will populate automatically.

  6. Click Add Subnet, and then click OK.
  7. Verify that that targeted workstation is running and connected to the network. 
  8. Expand Administration and Reporting and select Scheduled Tasks. 
  9. Select the task.
  10. Right-click the task and select Run Task Now.
    The Wake on LAN and Shut Down tasks should work properly when the discovery is completed.  
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