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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Unable to retrieve the computer group by ID for enumeration

Unable to retrieve the computer group by ID for enumeration

Updated March 24, 2017

Issue

When you expand Enterprise > Update Services > <WSUS_Server> > Computer and Groups in the navigation pane and select a computer group, the following error displays: 

Unable to retrieve the computer group by ID for enumeration

Environment

All Patch Manager versions 

Cause 

The Patch Manager Admin Console has cached data, causing a synchronization issue with the WSUS Console.

Resolution

Clear the caches and view layouts in the console.

  1. Log in to the Patch Manager Admin Console
  2. Select Administration and Reporting.
  3. Click General Settings in the center pane. 
  4. Click on Clear Caches and View Layouts.
  5. Click Clear Caches, and then click Clear View Layouts.
  6. Click OK. 
  7. Close Patch Manager
  8. Restart the EminentWare service
  9. Navigate to %AppData%\Roaming\Microsoft\MMC
  10. Delete the SolarWinds entry
  11. Open Patch Manager
  12. In the navigation pane, expand Enterprise and select Update Services.
  13. In the Actions pane, click Refresh.
  14. Reload the group.

See Clearing Caches, Layouts, Tasks, and Packages for more information. 

 

 

 

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