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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Troubleshooting Microsoft Installer Error Messages and Failures

Troubleshooting Microsoft Installer Error Messages and Failures

Created by Seamus.Enright, last modified by Steve.Hawkins on Mar 15, 2018

Views: 997 Votes: 0 Revisions: 9

Overview

When you deploy an MSI package with Patch Manager, the installation fails. 

Environment

Patch Manager

Cause

Issue at the installer level rather than the Patch Manager level.

Steps

To troubleshoot MSI errors, perform one of the following procedures:

Run the installer from the command line

Run the installer from a command line interface (CLI). This allows you to mimic the Windows Update Agent and observe exactly where and why the install fails.

  1. Check your installer package in Patch Manager for the command line parameters it is using for the installer. For example, some packages use /a to run the installer as an administrator.
  2. If necessary, move the installer file to the client system. Generally, when the installer fails on a client system, the installer is still available because the client downloaded the installer to their system.
  3. Open a Command Prompt (cmd.exe) on the client system and change directories to the location of the installer.
  4. Run the installer with the same command line parameters used by the package.

    For example, for sample.msi with the command line parameter /a, enter: 

    msiexec /a sample.msi

    To run a Microsoft Installer from the CLI, start the command with msiexec.

  5. Monitor the CLI output during the installation process, looking for specific errors or messages about where or why the installer failed.
  6. If possible, resolve the issue and re-try the installer.

Troubleshoot with MSI logging

  1. Enable MSI logging.
    See How to enable Windows installer logging  for instructions. (© 2018 Microsoft Corporation, available at http://www.microsoft.com/, obtained on March 15, 2018)
  2. Check the following locations for the installer log and search for errors and information to help with troubleshooting:
    • %appdata%\local\temp
    • %windir%\temp
    • %ProgramFiles%\programName, where programName is the name of the program you are installing. In other words, the installation folder used by the MSI.

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

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