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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Troubleshoot "Invalid Namespace" Errors - server or managed clients

Troubleshoot "Invalid Namespace" Errors - server or managed clients

Created by Brandon Painter, last modified by Steve.Hawkins on Mar 15, 2018

Views: 13,142 Votes: 0 Revisions: 6

Overview

Invalid namespace errors from either the Patch Manager server or managed clients.

Environment

All Patch Manager versions

Cause 

The WMI Providers are not accessible by the server or not present on the clients. This issue can be caused by:

  • User Account Control (UAC) interference
  • Missing WMI Providers

Resolution

Troubleshoot errors on servers

Patch Manager usually returns the Invalid namespace error on Patch Manager servers when the UAC prevents the server from communicating with the WSUS server. To resolve this issue, select one of the following options:

  • Disable UAC on the Patch Manager server
  • Use the built-in local Administrator account to communicate with your WSUS server

Set the built-in local Administrator account to communicate with the WSUS server

  1. Log in to the Patch Manager Admin Console. 
  2. In the navigation pane, expand Patch Manager System Configuration and select Security and User Management.
  3. In the center pane, click the Credentials tab.
  4. If the built-in local Administrator account displays in the tab window, go to the next step.
    If the built-in local Administrator account does not display in the tab window, add the credential.
    1. In the Actions pane, click Add Credential.
    2. Enter .\administrator in the User name field.
      If you renamed the built-in local Administrator account, replace "administrator" with the custom name.
    3. Enter and confirm the password for the built-in Administrator account.
    4. Click Save.
  5. Click the Credential Rings tab.
  6. Select the Credential Ring you want to modify, and then click Credential Ring Wizard in the Actions pane.
  7. Select the built-in local Administrator account from the User Name menu, and then click Add.
  8. Click Next.
  9. Add a Computer Rule for the Patch Manager server to tell it to use the local Administrator account:
    1. In the Create or modify Credential Rules screen, click Add Rule, and then select Computer.
    2. In the Select Computer screen, select Update Services Servers in the left pane.
    3. In the center pane, select the WSUS server, and then click Add selected.
    4. Click OK.
    5. In the Select User for Credential Rule screen, select .\administrator or the appropriate custom built-in Administrator account, and then click OK.
  10. Click Finish to close the Credential and Credential Rings Rules Wizard.

Troubleshoot errors on client systems

Patch Manager usually returns the Invalid namespace error for managed clients when they do not have the requisite WMI Providers installed.

To begin, disable the anti-virus software on the client. If this does not resolve the issue, install the WMI Providers on the client. 

If the Invalid namespace error contains an Invalid Signature message, an issue exists with the remote computer's root certificates store. To resolve this issue, update the root certificates store on the remote computer. See "Invalid Signature" error when attempting configuration management tasks on remote systems for more information.

Install WMI Providers on managed clients

Run the Computer Access Management task to install the WMI Providers. 

  1. In the Patch Manager Admin Console, locate and select the group that includes the affected computer.
  2. To run the task for that group of computers, click Check and Manage Computer Connectivity in the Actions pane.
  3. To run the task for a specific computer, select the computer in the center pane, and then click Check and Manage Computer Connectivity in the Actions pane.
  4. In the Computer Access Management window, select Install the WMI Providers if not already installed, and then select the applicable sub-options.
  5. Select all of the options outside of the SolarWinds WMI Providers Actions group except Enable DCOM if disabled.
  6. Click OK to run the task.
    If the Computer Access Management task cannot install the WMI Providers remotely, see Troubleshoot "Access Denied" errors in Patch Manager.

 

 

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