Submit a ticketCall us

WebinarWebinar: A checklist for planning your Network Performance Monitor (NPM) upgrade

Are you ready for your next upgrade? To help you plan smoothly, join this webcast to learn more about, SolarWinds® Orion® Installer, SolarWinds Upgrade Advisor, Upgrades Guides, Training Videos, and other resources available. We’ll share key upgrade planning considerations, lessons learned from customers with practical advice from SolarWinds Product Experts. We’ll also give practical tips to identify the estimated time needed and resources, how to prepare the business and IT staff for changes, ways to plan for required system changes, and more.

Register now.

Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Task execution errors in the Patch Manager Web Console

Task execution errors in the Patch Manager Web Console

Updated Aug 20, 2018

Overview

When you use Patch Manager, you may experience the following issues:

  • Patch Manager reports do not display any results.
  • Patch Manager Summary dashboard in the Orion Web Console displays task execution errors.

clipboard_e3105fe5765b19535470635ebcf605ae6.png

  • When you access any update views in Update Services node, they time out intermittently. However, you can access the same views in the WSUS native console directly without any errors.
  • When you run any scheduled task, it completes unusually fast and no error message is displayed in the MMC console.
  • Scheduled and update management tasks hang.
  • When you access task history view in the Patch Manager Console, it returns a connection timeout error with a message as shown below in the logs.
2018-05-01 06:37:07,315 [STP SmartThreadPool Thread #102] 
ERROR SolarWinds.PM.InformationService.Tasks.TaskExecutionHelper - 
Exception occured when executing task from template wsusupdates.xml deviceId f9cfccad-102e-4fce-a1ec-cbca29514f71. 
Error: Device ID: f9cfccad-102e-4fce-a1ec-cbca29514f71
Task ID: cde2d9ce-d000-439d-acf0-8e0560c25f5e
Device Info: SRV-RDC-AV02
Object Info: update
Source: Data Grid Server (SRV-RDC-AV02)
Reason: Exception occurred at 5/1/2018 6:37:04 AM: The operation has timed out

Environment

  • Patch Manager 2.x
  • Patch Manager Orion web interface installed on the Orion server
  • SQL Server Express installed locally for the EminentWare (Patch Manager) database

Cause 

  • When you installed Patch Manager, you chose SQL Server Express for your EminentWare database. SQL Server Express has a 10 GB limit. If your database exceeds this limit, Patch Manager may not operate as expected.
  • PM summary view page, has wrong login details to access the PAS

Resolution

  • Verify PM summary view settings have correct username and password to access the PAS, if the password is changed then update it here.
  • If Eminentware DB is using SQL express edition, then migrate your EminentWare database to an SQL Server Standard or Enterprise Edition instance.

You can also choose one of the following options:

  • Set up the managed computer inventory to inventory only the essential systems that require updates. Also, customize the computer inventory tasks to retrieve updates only for the required software running on each system.
  • Shrink the EminentWare database using SQL Server Management Studio. When you are finished, clear the caches and task history and schedule a regular WSUS server cleanup.

    Back up your database before you perform this operation. Shrinking the database may result in some data loss. 

 

 

Last modified

Tags

Classifications

Public