Submit a ticketCall us

whitepaperYour VM Perplexities Called, and They Need You to Read This.

Virtualization can give you enormous flexibility with future workloads and can be a key enabler for other areas, like cloud computing and disaster recovery. So, how can you get a handle on the performance challenges in your virtual environment and manage deployments without erasing the potential upside? Learn the four key areas you need to be focusing on to help deliver a healthy and well-performing data center.

Get your free white paper.

Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Error after backing up and restoring the EminentWare database to SQL Server 2016

Error after backing up and restoring the EminentWare database to SQL Server 2016

Updated December 7, 2017

Overview

The following error occurs when restarting the EminentWare service after performing a backup and restore of the EminentWare databaseto SQL Server 2016 from an older version:

Service cannot be started. System.Exception: Incorrect syntax near 'TRIPLE_DES'.
at EminentWare.DataGridService.DataGridService.OnStart(String[] args)
at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

Environment

  • Patch Manager 2.1.3
  • Microsoft® SQL Server® 2016

Cause 

  • TRIPLE_DES is deprecated in SQL Server 2016
  • As of Patch Manager 2.1.3, we only support SQL Server 2014 and earlier.

Workaround

  1. Change the EminentWare DB compatibility to SQL Server 2014 mode.
  2. Start the EminentWare Data Grid Service.
    Patch Manager should now operate normally. 

 

Last modified

Tags

Classifications

Public