Submit a ticketCall us

AnnouncementsChange Is Inevitable

Get valuable help when it comes to tracking and monitoring changes. SolarWinds® Server Configuration Monitor (SCM) is designed to help you: detect, track, and receive alerts when changes occur, correlate system performance against configuration changes, compare server and application configuration against custom baselines, and verify application and system changes.

Learn more.

Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Patch Manager version error in the Orion Web Console

Patch Manager version error in the Orion Web Console

Updated December 5, 2017

Overview

The Orion Web Console displays the following error message, indicating that Patch Manager is running the wrong version:

 

The Patch Manager Server version (version number) is greater than the Patch Manager console version (version number) and may not be compatible.

 

In this message, the Patch Manager Server version is the version of the Patch Manager Primary Application Server and the Patch Manager Console version is the version used in the Orion Web Console. 

Environment

  • All Orion Core products
  • Patch Manager version 1.8 and later

Cause 

  • Version mismatch between the Orion Web Console and Patch Manager.
  • An update was deployed incorrectly. 
  • A hotfix or upgrade is installed on the Patch Manager Console or an Automation Server but not on the Orion Web Console.

Resolution

  1. Check the current versions on each server.
  2. Install the latest hotfix or update both servers.
  3. Perform additional troubleshooting (if needed).  

Check the current version

  1. Open Windows Programs and Features through the Windows Control Panel.
  2. Locate SolarWinds Patch Manager.
  3. Compare the versions on each server. If there is a mismatch, install the correct version. 

Install the latest hotfix or update both servers

  1. Log in to the Orion Platform server. 
  2. Run the installer or update file. 
  3. In the Install Wizard, select only the Web Console updates.
  4. Complete the installer. 

Additional troubleshooting

If the version mismatch continues and the Patch Manager version is version 2.1 or earlier, perform the following steps:

  1. Backup the following file:
    %ProgramFiles(x86)%\SolarWinds\Orion\Information Service\2\EminentWare.BusinessObjects.dll.
  2. Stop the SolarWinds Information Service on the Web Console server.
    This will stop the Web Console functioning correctly while it is stopped.
  3. Log in to the Patch Manager Primary Application Server as an administrator.
  4. Navigate to:
    %ProgramFiles%\SolarWinds\Patch Manager\Server\
  5. Log in to the Web Console server as an administrator.
  6. Navigate to:
    %ProgramFiles(x86)%\SolarWinds\Orion\Information Service\2.0
  7. On the Primary Application server, copy the EminentWare.BusinessObjects.dll file from the \Server directory to the \2.0 directory on the Web Console server. 
  8. Restart the SolarWinds Information Service.
  9. Verify that the mismatch error message does not display in the Orion Web Console. 

 

Last modified

Tags

Classifications

Public