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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > No connection could be made because the target machine actively refused it

No connection could be made because the target machine actively refused it

Overview

When you add a WSUS server to Patch Manager, the following error displays:

Could not connect to server:

Exception occurred at 

No connection could be made because the target machine actively refused it 

Environment

Patch Manager 2.1 and earlier

Cause 

The WSUS server is not responding on the appropriate port. As a result, Patch Manager cannot connect to the WSUS server.

Resolution

Verify that:

  1. The WSUS server is installed and configured properly.
  2. The WSUS listening port is correct. 
  3. Patch Manager is able to resolve the WSUS server and the port included in the Connection Wizard is correct. 
  4. The WSUS server has no errors in the Windows Event and Application logs and is functioning correctly.

 

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