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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Approving more than four updates at a time fails

Approving more than four updates at a time fails

Updated: June 27, 2016

Overview

The Patch Manager Manager Administrator Console includes a menu that allows you to approve updates in Windows Server Update Services (WSUS) server. During this process, an Approval task is generated in Task History when it is completed.

If this action occurs, the Primary Application Server (PAS) and WSUS server certificate stores may have duplicate certificates.

Environment

  • All Patch Manager versions

Cause 

Duplicate certificates in the PAS and WSUS server Certificates stores.

Resolution

Check the certificate in the Patch Admin Console

Verify the Publishing Certificate in the Patch Manager Console.

  1. Log in to the Patch Manager Administrator Console as administrator.
  2. Expand Enterprise > Update Services and select the primary WSUS server.
  3. In the Actions pane, select Software Publishing Certificate.
  4. Note the Expiration Date and Thumbprint.

Check the certificates in the WSUS and PAS

Verify that the software publishing certificate is present in the Trusted Root and Trusted Publishers store on the WSUS, PAS, and the WSUS certificate store on the WSUS server.

Perform the following steps on each machine:

  1. Log in to the server.
  2. Navigate to Apps.
  3. Launch the Microsoft Management Console.
    In the Search box, enter mmc and start the MMC.
  4. Click File > Add or Remove Snap-in.
  5. In the Available snap-ins list, select Certificates and click Add.
  6. Select Computer Account and click Next.
  7. Select Local Computer and click Finish.
  8. In the Add or Remove Snap-ins window, click OK.
  9. Expand the Certificates module and review the following Certificate Stores:
    • Trusted Root Certification Authorities
    • Trusted Publishers
    • WSUS (WSUS server only).
  10. Verify that the Expiration Date and Thumbprint from each certificate in step 3 is a match.
  11. Remove any duplicates (if available).
  12. Close the Patch Manager console.
  13. Restart the EminentWare Data Grid Server Service.
  14. Launch the console.
  15. Repeat the approval task. 
 

 

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