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Home > Success Center > Patch Manager > Patch Manager - Knowledgebase Articles > Access Denied error when adding users to a security role

Access Denied error when adding users to a security role

Updated March 6, 2016

Overview

When you add users to a security role in the Patch Manager System Configuration > Security and User Management > Security Roles tab, SolarWinds Patch Manager generates the following error: 

Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

 

Environment

All SolarWinds Patch Manager versions

Cause 

This error is caused by one of the following issues: 

  • User Account Control (UAC) is enabled on the server.
  • Credential Ring is not configured correctly.

Resolution

Disable UAC

  1. Log on to the SolarWinds Patch Manager server as an administrator.
  2. Navigate to Control Panel > Action Center and expand Security. 
  3. Under User Account Control, select Change Settings.

    You will need administrative privileges to make this change.

  4. In the User Account Control Settings set the slider to the bottom option: Never notify.
  5. Reboot the server. 

Reconfigure the Credential Ring

In some cases, a misconfigured Credential Ring will cause this issue. Be sure that:

  • Rules exist only to resolve an issue. 
  • The appropriate credential is assigned to the rule.
  • Delete old user credentials still exists that no longer exists and user the current AD login details

For additional information review Managing Credential Rings.

For assistance, contact Support

Check Acccount Running EWDGS Service for Administrator Rights

If account running the service looses administrator rights it will no longer be able to update the database.

  • Launch services.msc
  • Find the account used for service most likely ./ewdgsvc####
  • Launch Computer Management
  • Look at properties of user
  • Check group membership
  • Add Administrators

 

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