Updated February 9, 2017
Overview
You receive the following error message when adding a new WSUS server and clicking on it under Update Services:
Key not valid for user in specified state.

Environment
- All Patch Manager versions
- You are receiving this error in your PAS
- You are not using the default service account
Cause
The issued EminentWare certificates does not have the permission to use the service account provided.
Resolution
- Open mmc from Start > Run.
- Go to File > Add/Remove Snap-in and add Certificates for your Computer account.
- Delete the two EminentWare ceriifcates from Trusted Root Certification Authorities.
- Open regedit from Start > Run and browse to HKLM\Software\EminentWare\Data Grid Service.
- Delete the DeviceID and CADeviceID keys.
- Open an admin Command Prompt and go to C:\Program Files\SolarWinds\Patch Manager\server and run: setuphelper.exe /provisionserver /type primary
- Open your Patch Manager Console and go to Patch Manager System Configuration > Security and User Management.
- Choose your service account in the Credentials tab, click Change Password, and enter that account's password.
- Go to Patch Manager System Configuration > Patch Manager Servers and click Patch Manager Server Wizard in the Actions area.
- Choose the Edit option and complete the wizard.