Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

 

 

 

Home > Success Center > Patch Manager > "Key not valid for use in specified state" exception error when attempting to publish third party packages

"Key not valid for use in specified state" exception error when attempting to publish third party packages

Created by Interspire Import, last modified by MindTouch Content Copy on Nov 13, 2015

Views: 1 Votes: 0 Revisions: 7

Overview

When you try to publish third party updates, you receive an exception message similar to the following:

"Source: EminentWare.UI.Publisher

Exception occurred at 8/2/2013: Key not valid for use in specified state."

Environment

All Patch Manager versions

Cause

This is caused by deprecated authentication information in the database from older versions of Patch Manager.

Resolution

Remove the erroneous database entry by performing the following steps.

  1. In Patch Manager, navigate to Patch Manager System Configuration > Patch Manager Servers > Application Servers, and select your application server in the center pane.
  2. Click the Application Server Settings tab.
  3. Type text into the Username and Password fields.
  4. Click Save.
  5. Delete the text in the Username and Password fields.
  6. Click Save.

If you still receive the same error, delete the text in the Proxy Domain and Server Name fields.

Last modified
14:52, 13 Nov 2015

Tags

Classifications

Public